Después de varios aplazamientos, por fin la versión de WordPress 5.0 se lanzará el día de hoy, 6 de diciembre. Para gusto de algunos y disgustos de muchos, esta versión trae un cambio radical en el editor de WordPress. El nuevo editor llamado en código como Gutenberg, es un cambio sustancial en la funcionalidad de escribir nuevos artículos y páginas ya que utiliza un nuevo sistema basado en bloques para la edición que le permite incrustar una amplia gama de contenido en sus publicaciones y páginas, y le brinda mucha flexibilidad para diseñar esos bloques en la página.

Se espera que una vez el nuevo editor Gutenberg y la versión WordPress 5.0 se hayan estabilizado, brindarán beneficios a largo plazo a los usuarios de WordPress y a toda la comunidad de desarrolladores. Sólo que a corto plazo, este cambio puede presentar desafíos para algunos propietarios de sitios de WordPress sobre todo a los acostumbrados a la redacción de texto simple.

¿Preparado para Wordpress 5.0? Lo que debes saber antes de la actualización 2

La intención de este artículo es analizar algunos puntos que lo ayudarán a decidir cuándo actualizar a WordPress 5.0 y cómo realizar una transición exitosa al nuevo editor de manera progresiva.

¿Por qué está cambiando WordPress el editor clásico?

El equipo de desarrollo central de WordPress ha estado hablando de Gutenberg durante bastante tiempo. El objetivo, según Matt Mullenweg, es “simplificar la experiencia del usuario por primera vez con WordPress, para aquellos que escriben, editan, publican y diseñan páginas web. El objetivo de la experiencia de edición es brindar a los usuarios una mejor representación visual de cómo se verá su publicación o página cuando presionen «. En general, estamos de acuerdo en que Gutenberg será un gran paso adelante en el uso de WordPress para crear contenido en línea. Pero, como Matt declaró, el objetivo es simplificar la experiencia para el usuario que utiliza por primera vez. Para el resto de nosotros que hemos reunido una serie de herramientas para llenar los vacíos en las deficiencias del editor anterior, este será un período de ajuste.

Problemas potenciales con los complementos y temas heredados

WordPress ha existido durante más de 15 años, y en ese momento se han creado millones de sitios web utilizando el marco de edición actual. A menudo, los sitios se crean y nunca se actualizan a temas más modernos. Hay una gran cantidad de complementos abandonados instalados en los sitios de WordPress, que ya no son mantenidos activamente por sus desarrolladores. Nadie está probando estos complementos abandonados o temas más antiguos para ver cómo se comportarán con Gutenberg. Además de la complejidad, muchos de estos sitios pueden hospedarse en los servicios de alojamiento de WordPress administrados que se actualizarán automáticamente a la nueva versión de WordPress.

Es posible que algunos propietarios de sitios de WordPress no puedan editar eficazmente las páginas que habían publicado anteriormente. Es posible que algunos no puedan acceder a su pantalla de edición. Puede haber errores del servidor 500 o pantallas blancas para algunos usuarios. O todo puede funcionar sin problemas, incluso con complementos heredados y un tema heredado. Con más de 60,000 complementos únicos en el directorio de complementos de WordPress, no es posible probar todos los complementos con el nuevo editor. Los complementos mantenidos activamente son, en su mayor parte, probados por sus autores. Los complementos abandonados no se han probado, por lo que depende de usted comprobar si WordPress 5.0 funcionará con estos complementos. Lo mismo se aplica a los temas. Muchos temas son mantenidos activamente por sus autores. En otros casos, un tema puede haber sido creado como un solo proyecto para un cliente o creado para la comunidad y luego dejado sin mantenimiento.

Estos temas no mantenidos no se han probado con Gutenberg y WordPress 5.0. Si anticipa problemas de compatibilidad con WordPress 5.0, puede mantener el editor de WordPress actual instalando el complemento WordPress Classic Editor. Le recomendamos que lo haga con anticipación, en lugar de intentar usar el nuevo editor con código incompatible. Pero también vale la pena señalar que Gutenberg y WordPress 5.0 son un importante paso adelante en el poder de edición y la flexibilidad. Por lo tanto, vale la pena invertir el tiempo para hacer que su sitio sea compatible, modificarlo si es necesario y luego aprovechar los beneficios de un nuevo editor basado en bloques.

La versión actual del núcleo de WordPress es 4.9.8. Si permanece en esta versión, continuará recibiendo actualizaciones de seguridad del equipo central de WordPress. La política actual del equipo de seguridad de WordPress es respaldar las correcciones de seguridad de todas las versiones principales de WordPress compatibles con actualización automática. Eso significa que todas las versiones del núcleo de WordPress continuarán recibiendo actualizaciones de seguridad de regreso a WordPress 3.7.